monetizer expertmobi
Dismiss Notice
Welcome to Our Community
Wanting to join the rest of our members? Feel free to sign up today.

Need Help With WordPress .htaccess | URL Re-Writing

Discussion in 'General Internet Marketing' started by apondonet, May 17, 2006.

  1. apondonet

    apondonet New Member

    17
    0
    0
    I have Wordpress installation (Ver. 2.0.1) that's been giving me headaches the last few days.

    Here is what's happening:

    In the admin panel I have set the permalink options (OPTIONS --> PERMALINK --> ) to the "Date and name based" option in the options list. My URLS are re-written to look like this: /blog/wordpress/index.php/2006/05/14/sample-post/

    All URLs seem to work OK despite the fact that wordpress does not update the .htaccess file in installation root: /wordpress/ -- the .htaccess remains blank even when CHMODED to 777.

    While the URLs seem to work fine the RSS FEED URLs generated for the MAIN FEED & COMMENTS are blank when viewed in a browser or a feed aggregator. Here is the feed format: /blog/wordpress/index.php/feed/ .

    The same format appears in the the automatically generated AUTO-DISCOVERY tags, meaning the search engines are essentially picking nothing.

    What heck is happening here?

    Note: The default RSS feed URLs work fine:

    Main Feed: /blog/wordpress/?feed=rss2
    Comments Feed: /blog/wordpress/?feed=comments-rss2
     
  2. monetizer
  3. Teli

    Teli Affiliate affiliate

    306
    21
    0
    Actually, the permalink structure you're using doesn't require .htaccess rewrite rules (that's why it's still blank). This structure previously caused problems in WP 1.2.x & 1.5.x, but it's much more rare with 2.0.x, so there may be other factors at play.

    Without a URL to play with, it is more difficult to figure out what the specific problem for your website is. I would suggest changing the permalink structure to something else (removing the index.php portion) to see if it still gives you the same error. Be forewarned that you will need to update the .htaccess file for the new structure.

    If the feeds start working, then you'll know it's a problem using index.php and if not, it may be a feed specific problem or even a problem with your content.

    ~ Teli
     
  4. apondonet

    apondonet New Member

    17
    0
    0
    Teli:

    Thanks for your quick answer!

    Do you have any sample .htaccess code I could play around with.
     
  5. Teli

    Teli Affiliate affiliate

    306
    21
    0
    WordPress will create the .htaccess code for your automatically. Simply make sure your .htaccess file isn't writable, change your permalink structure in WP and it will spit out some code for you, copy it to notepad, and change your permalink structure back.

    Instant .htaccess sandbox code - and it will be specific to your site.

    ~ Teli

    By the way, do you have a name apondonet? Normally, I don't mind calling someone by their username, but it just seems strange...
     
  6. apondonet

    apondonet New Member

    17
    0
    0
  7. Teli

    Teli Affiliate affiliate

    306
    21
    0
    Hi James, pleasure to meet ya :)
     
  8. Linda Buquet

    Linda Buquet <span style="color: #daa520;font-weight: bold;">Me

    15,098
    736
    0
    Thanks Teli for jumping right in.

    James Teli is the WP guru in case you couldn't tell.

    Moved this to the RSS forum and out of the affilaite forum just to keep things more organzied by topic.
     
  9. apondonet

    apondonet New Member

    17
    0
    0
    Teli:

    I did exactly as you said and selected the Custom structure: /%year%/%monthnum%/%day%/%postname%/ in Admin

    WordPress spit out the following code for .htaccess:

    Code:
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /blog/wordpress/
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /blog/wordpress/index.php [L]
    </IfModule>
    The URLs still have 'index.php' in them for example:
    /blog/wordpress/index.php/category/marketing/
    /blog/wordpress/index.php/2006/05/14/website-update-05-14-2006/

    How do I remove the index.php in the URL?

    Also, all other URLs work fine except the Main RSS URLs which still are in the format:
    /blog/wordpress/feed/
    /blog/wordpress/comments/feed/

    ...and do not work. I guess they are re-written incorrectly. I believe the fix is a code snippet for .htaccess

    The odd thing is that the Category feeds which are in the same format: /blog/wordpress/category/marketing/feed/ work fine!!

    Any ideas?
     
  10. apondonet

    apondonet New Member

    17
    0
    0
    Miracle!

    I added a comment to one of the posts and booom.... everything fixed itself: The "index.php" has disappeared from the URLs and the feeds are now working fine.

    How this happened beats me. I am just glad everything is working OK now.

    Thanks for your help Teli. I will get back to you if I experience any more problems.

    What a relief!
     
  11. apondonet

    apondonet New Member

    17
    0
    0
    Here is one for you Teli:

    After clicking the SAVE button when posting I get a blank page with post.php at the end of the URL.

    This seems to be a widespread problem and I haven't been able to solve it.

    Any ideas?
     
  12. apondonet

    apondonet New Member

    17
    0
    0
    Still waiting for an answer on this one. Haven't found a solution yet!
     
  13. Teli

    Teli Affiliate affiliate

    306
    21
    0
    Actually, there isn't a simple solution as the problem has been linked to a number of things including the ping list you have set up. If one of the sites isn't responding properly, it could cause the post script to choke. It could also be server settings, which could cause the post script to choke, and it could also be the content within the post which is causing the post script to choke.

    I would recommend deleting all the websites in your ping list and try posting again. If the entry publishes without a problem, chances are it's a website in the ping list or the ping list was just too long to begin with.

    If the problem still occurs, try altering the post content to see if that may be the problem. And if that still doesn't help, chances are that it's a server issue.

    Hope that gets you in the right direction,
    ~ Teli
     
  14. StephenR

    StephenR Affiliate affiliate

    340
    7
    0
    Teli is absolutely correct James. Nowadays there's really no reason IMHO to have an extensive list of ping directories. You can still test it but there are only a handful of authority ping sites you need to be concerned about.

    HEADS UP for all of you WordPress users. You may want to consider coverting your feeds to the Feedburner format. You can accomplish this by downloading the WordPress Feedburner Plugin. This plugin is stable and I use it on all my WP blogs.
     
  15. apondonet

    apondonet New Member

    17
    0
    0
    That seems to be the problem. Quite accurately diagnosed. Thank you very much Teli and co.

    Question:

    Which of these do you regard as authority ping sites. Note - The default for WordPress is - http://rpc.pingomatic.com/

    Here is the list:

     
  16. StephenR

    StephenR Affiliate affiliate

    340
    7
    0
    If you want to knock out all the major directories in one shot take a look at the following XML-RPC sites compiled by Robin Good from MasterNewMedia. I didn't re-check all these so some may now be obsolete.

    The URLs between parentheses are not regular hyperlinks, but addresses of the respective ping services belonging to each directory.


    Blo.gs (service URL: http://ping.blo.gs/) - verified

    Weblogs (service URL: http://rpc.weblogs.com/RPC2) - ambiguous results

    FeedBurner has a service called PingShot. With this service, FeedBurner automatically pings the services every time you add a new entry. It requires using FeedBurner for your feeds.

    Technorati (service URL: http://rpc.technorati.com/rpc/ping) - verified
    Technorati Ping Configurations - Detailed instructions

    MyYahoo! (service URL: http://api.my.yahoo.com/rss/ping) - not found

    BlogChatter (service URL: http://www.mod-pubsub.org/kn_apps/blogchatter/ping.php) - not clear how this is supposed to work (site and link not working at last check)

    PubSub (service URL: http://xping.pubsub.com/ping/) - not updated

    BlogDigger (service URL: http://www.blogdigger.com/RPC2)- unverified

    Feedster (service URL: http://api.feedster.com/ping.php) - requires feed to be manually submitted first; not yet verified

    BlogRolling (service URL: http://rpc.blogrolling.com/pinger/) - not updated

    BlogStreet (service URL: http://www.blogstreet.com/xrbin/xmlrpc.cgi) requires one-time manual blog URL submission

    Moreover (service URL: http://api.moreover.com/ping) - not yet verified

    Weblogalot (service URL: http://ping.weblogalot.com/rpc.php) - not yet verified

    IceRocket (service URL: http://rpc.icerocket.com:10080/) - not yet verified

    TopicExchange (service URL: http://topicexchange.com/RPC2) - not yet verified

    BlogShares (service URL: http://www.blogshares.com/rpc.php) retrieves its data from weblogs.com; requires one-time manual submission not yet verified

    NewsIsFree (service URL: http://www.newsisfree.com/xmlrpctest.php3) not yet verified

    Blog Buzz Machine (service URL: http://rpc.blogbuzzmachine.com/RPC2) not verified
     

Featured Resources (View All)

MI