propellerads adcombo
Dismiss Notice
Welcome to Our Community
Wanting to join the rest of our members? Feel free to sign up today.

Campaign HELP! What Am I Doing Wrong?

Discussion in 'Newbie Helpdesk' started by azgold, Feb 1, 2014.

  1. azgold

    azgold Moderator moderator affiliate

    6,166
    2,230
    113
    Hi, guys. I am running a dating display campaign that I've been having trouble with from the word, "go." I'm hoping you can help me. This is a Saturday night and close to Valentine's Day, so I really want to take advantage of that.

    Every step with this campaign has been a challenge, from link rejection to landing pages not working to having to switch networks to run it. All that has been sorted out now and I learned things along the way, so there has been value in it for me.

    The urgent issue I'm having now is that the links are not working - not the bit.ly'd Bevo link, nor the raw link from the network. When I checked my 7Search account, I saw that traffic was picking up pretty nicely and I had a few clicks. I decided to check my landing page stats - it said that no one had landed. Hmmm. So, I grabbed both the bit.ly and the raw link from the network and put them into two different proxies. The bit.ly link went to a totally different website (same vertical but adult) and the raw link resulted in a "not recognized as a valid url" message.

    Those links worked this morning, my AM kindly double checked them for me. What am I doing wrong? Or is there something I didn't do that I should have? :confused:

    I am really tearing my hair out with this one! This is the wrong night for it to happen.

    I'd be really grateful for any helpful advice.

    Thanks.
    Shirley
     
  2. java

    java Affiliate affiliate

    195
    25
    18
    When placing your tracking link into 7search you shouldn't be using blitly link as your keywords and partner id wil not pass through. Use the tracking link that was generated. also I've heard of people putting geo location on their landing pages. make sure you have a default (no geo target) for a landing page. did you use LP code generated on your landing pages ?
     
  3. T J Tutor

    T J Tutor Administrator Administrator moderator affiliate

    7,328
    3,078
    113
    Are you using Geo scripts of any kind? I do, but sometimes this can interfere with the use of some proxies. I've had this issue with HideMyAss on a couple of occasions recently. Also, have you checked with Ryan or Steve at BEVO to be certain that your tracking setup is correct? In the BEVO interface there is an option for cloaking. If you are using a combination of Bitly and the BEVO cloaking then you may have errors when trying to view the pages. Check to be certain you are not cloaking twice. The cloaking in BEVO is sufficient. I would return to BEVO, re-build the campaign with no cloaking, and don't add any other cloaking. Just build a very simple tracking campaign and then check to see if your links work. If they do, then go back and build another tracking campaign with the BEVO Cloak and see if your links for that work. You need to add one element at a time to see where the deficiency develops. You're on the right track, there is likely just a simple element out of place.
     
    1 person likes this.
  4. azgold

    azgold Moderator moderator affiliate

    6,166
    2,230
    113
    Really? Bevo gives Bit.ly as a short link, I didn't realize, thanks. You mean the tracking link from the network or Bevo? Or either?

    No, I have no idea how to put geo location on a landing page, so no. I sent the traffic from 7S to landing pages on my WP blog. I don't know how to do much else in that regard, yet.

    Thank-you for the info!
     
  5. azgold

    azgold Moderator moderator affiliate

    6,166
    2,230
    113
    Had to travel last night, had hoped to fix things before I left for my daughter's for a week but alas, didn't happen. I won't be online much for the next few days but I'm going to keep playing with this thing until I get it working! It's frustrating the hell outta me but if I conquer it, I have a feeling it will be an invaluable experience. Plus, I've thrown up my hands and let the panic go that I was feeling. Until I learn how to deal with these things, stuff is likely to happen.

    I really, really appreciate your help!
     
    Last edited: Feb 2, 2014
  6. azgold

    azgold Moderator moderator affiliate

    6,166
    2,230
    113
    I did some more investigation on this. Followed your advice, TJ, deleted all the links, started again adding one element at a time. I did not fix my problem but going through that exercise helped to determine that the issue is the links from the landing pages to the offer site. Still don't have any idea why as I changed them to the direct links from the network but at least I know where the problem lies. Now that I have it isolated, maybe I can figure out the solution.
     
  7. T J Tutor

    T J Tutor Administrator Administrator moderator affiliate

    7,328
    3,078
    113
    Okay, I think I know where the issue may be. Are you creating a .php file and link on your landing page?
     
  8. azgold

    azgold Moderator moderator affiliate

    6,166
    2,230
    113
    No idea, not on purpose. I used the Wordpress Landing Pages plugin to create the landers, maybe it did? Seems to me it created iframes. At the end, I put in the direct offer link.

    Anyway, I'm not pushing that one anymore, it was paused. I will try more dating offers in future but not until I get better set up.

    I've decided that I'm going to spend more prep time before launching a campaign, from now on. Usually, I'm antsy to get going but that's next on my list of CPA self-improvement. :)

    Thank-you, TJ.
     
    Last edited: Feb 24, 2014
  9. operationoffers

    operationoffers Affiliate Manager Affiliate Manager affiliate

    664
    58
    28
    Glad it worked out for you. would going to say that it may have had something to do with Geo /Proxy issues, but looks like it was already hammered on. Good luck with any new campaigns you plan on running, Planning is always good and if you only have a day, it is probably not worth your headache.
     
  10. T J Tutor

    T J Tutor Administrator Administrator moderator affiliate

    7,328
    3,078
    113
    In most cases you will have to create a ".php" file when using landing pages on Bevo. This is often over looked when using Bevo to track a landing page. Let me know when you are ready to track a lander with Bevo and I'll show you how easy it is to do.
     
    1 person likes this.
  11. azgold

    azgold Moderator moderator affiliate

    6,166
    2,230
    113
    Thx, I will!
     

Featured Resources (View All)

adsxposed